Back to overview
Resolved

Dashboard errors during a Fly.io database incident

Aug 20, 2026 at 7:35am UTC
Affected services
Dashboard (app.quonfig.com)

Resolved
Aug 20, 2026 at 7:35am UTC

Between 07:11 and 07:35 UTC on 20 August, our hosting provider's managed Postgres service in the ORD region was partially down (Fly.io incident "MPG (v1) partially down in ORD": https://stspg.io/400fb1x28kty). app.quonfig.com could not reach its database for about 20 minutes and some dashboard requests returned errors. Config delivery to SDKs was not affected: the delivery API serves from an in-memory cache and kept authenticating previously-issued SDK keys throughout; we observed no failed config API requests. Service recovered when the provider restored the database cluster at 07:32 UTC.